import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+\\.\\w+)\"";
final String string = "<span>emoticon12</span><img src=\"qrc:\\res\\emoticon\\emo12.gif\" width=\"20\" height=\"20\"/><span>emoticon8</span><div>...</div><img src=\"qrc:\\res\\emoticon\\emo8.gif\" width=\"20\" height=\"20\"/>...<img src=\"qrc:\\res\\emoticon\\emo9.gif\" width=\"20\" height=\"20\"/>...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}