$re = '/(\w+\.\w+)"/m';
$str = '<span>emoticon12</span><img src="qrc:\\res\\emoticon\\emo12.gif" width="20" height="20"/><span>emoticon8</span><div>...</div><img src="qrc:\\res\\emoticon\\emo8.gif" width="20" height="20"/>...<img src="qrc:\\res\\emoticon\\emo9.gif" width="20" height="20"/>...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);