const regex = /[^\x00-\x7f£¢£€¥]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\x00-\\x7f£¢£€¥]+', 'g')
const str = `£5 off bookings at A1Travel`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);