import Foundation
let pattern = #"[^\x00-\x7f£¢£€¥]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"£5 off bookings at A1Travel"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)