use strict;
my $str = '£5 off bookings at A1Travel';
my $regex = qr/[^\x00-\x7f£¢£€¥]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";