#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a class="link" href="([^"]+)">([^<]+)<"
Local $sString = "<a class="link" href="pagedetail.html?record_id=123456">RecordName</a>" & @CRLF & _
"<a class="link" href="pagedetail.html?record_id=789012">RecordName2</a>" & @CRLF & _
"<a class="link" href="pagedetail.html?record_id=111111">RecordName3</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")