import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a class=\"link\" href=\"([^\"]+)\">([^<]+)<";
final String string = "<a class=\"link\" href=\"pagedetail.html?record_id=123456\">RecordName</a>\n"
+ "<a class=\"link\" href=\"pagedetail.html?record_id=789012\">RecordName2</a>\n"
+ "<a class=\"link\" href=\"pagedetail.html?record_id=111111\">RecordName3</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}