// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a class="link" href="([^"]+)">([^<]+)<"#).unwrap();
let string = "<a class=\"link\" href=\"pagedetail.html?record_id=123456\">RecordName</a>
<a class=\"link\" href=\"pagedetail.html?record_id=789012\">RecordName2</a>
<a class=\"link\" href=\"pagedetail.html?record_id=111111\">RecordName3</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}