import Foundation
let pattern = #"<a class="link" href="([^"]+)">([^<]+)<"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a class="link" href="pagedetail.html?record_id=123456">RecordName</a>
<a class="link" href="pagedetail.html?record_id=789012">RecordName2</a>
<a class="link" href="pagedetail.html?record_id=111111">RecordName3</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)