package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a class="link" href="([^"]+)">([^<]+)<`)
var str = `<a class="link" href="pagedetail.html?record_id=123456">RecordName</a>
<a class="link" href="pagedetail.html?record_id=789012">RecordName2</a>
<a class="link" href="pagedetail.html?record_id=111111">RecordName3</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}