$re = '/<a class="link" href="([^"]+)">([^<]+)</';
$str = '<a class="link" href="pagedetail.html?record_id=123456">RecordName</a>
<a class="link" href="pagedetail.html?record_id=789012">RecordName2</a>
<a class="link" href="pagedetail.html?record_id=111111">RecordName3</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);