#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(?:1[8-9]|[2-9][0-9]|100)\]"
Local $sString = "[17]" & @CRLF & _
"[18]" & @CRLF & _
"[66]" & @CRLF & _
"[99]" & @CRLF & _
"[100]" & @CRLF & _
"[101]" & @CRLF & _
"[666]" & @CRLF & _
"66"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")