import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:1[8-9]|[2-9][0-9]|100)\\]";
final String string = "[17]\n"
+ "[18]\n"
+ "[66]\n"
+ "[99]\n"
+ "[100]\n"
+ "[101]\n"
+ "[666]\n"
+ "66";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}