re = /\[(?:1[8-9]|[2-9][0-9]|100)\]/
str = '[17]
[18]
[66]
[99]
[100]
[101]
[666]
66'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end