import Foundation
let pattern = #"\[(?:1[8-9]|[2-9][0-9]|100)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[17]
[18]
[66]
[99]
[100]
[101]
[666]
66
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)