package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?:1[8-9]|[2-9][0-9]|100)\]`)
var str = `[17]
[18]
[66]
[99]
[100]
[101]
[666]
66`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}