using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:1[8-9]|[2-9][0-9]|100)\]";
string input = @"[17]
[18]
[66]
[99]
[100]
[101]
[666]
66";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}