$re = '/\[(?:1[8-9]|[2-9][0-9]|100)\]/';
$str = '[17]
[18]
[66]
[99]
[100]
[101]
[666]
66';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);