const regex = /\[(?:1[8-9]|[2-9][0-9]|100)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?:1[8-9]|[2-9][0-9]|100)\\]', 'g')
const str = `[17]
[18]
[66]
[99]
[100]
[101]
[666]
66`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}