# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?! )((?:ftp|http)[^ ]+)?/. $1 /g;t' <<< "See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here"