using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?! )((?:ftp|http)[^ ]+)?";
string substitution = @". $1 ";
string input = @"See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}