const regex = /\.(?! )((?:ftp|http)[^ ]+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?! )((?:ftp|http)[^ ]+)?', 'g')
const str = `See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here`;
const subst = `. $1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);