re = /\.(?! )((?:ftp|http)[^ ]+)?/
str = 'See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here'
subst = '. $1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result