import re
regex = re.compile(r"\.(?! )((?:ftp|http)[^ ]+)?")
test_str = "See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here"
subst = ". $1 "
result = regex.sub(subst, test_str)
if result:
print(result)