$re = '/\.(?! )((?:ftp|http)[^ ]+)?/';
$str = 'See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here';
$subst = ". $1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;