use strict;
my $str = 'See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here';
my $regex = qr/\.(?! )((?:ftp|http)[^ ]+)?/p;
my $subst = '. $1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";