#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.(?! )((?:ftp|http)[^ ]+)?"
Local $sString = "See also vadding.Constructions on this term abound.http://example.com/foo/bar some text here. and some texts here"
Local $sSubst = ". $1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)