# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*\\/).*/\1/g;t' <<< "Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
"