package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*\/).*`)
var str = `Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}