using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(.*\/).*";
        string substitution = @"\1";
        string input = @"Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
";
        
        Regex regex = new Regex(pattern);
        string result = regex.Replace(input, substitution);
    }
}