use strict;
my $str = 'Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt
Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt
';
my $regex = qr/(.*\/).*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";