import re
regex = re.compile(r"(.*\/).*")
test_str = ("Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.txt\n"
"Folder1/Folder2/Folder3.1234/folder4.5678/ApplesandOranges.zip?CatsAndDogs.txt\n")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)