using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)";
string input = @"Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}