import re
regex = re.compile(r"Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.\n"
"Hola, me llamo Ana, tengo 30 años y vivo en Valencia.\n"
"Me llamo Carlos, tengo 40 años y vivo en Madrid.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")