use strict;
my $str = 'Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.';
my $regex = qr/Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}