const regex = /Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Me llamo ([A-z]{3,}), tengo (\\d{1,3}) años y vivo en ([A-z]+)', 'gmi')
const str = `Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}