re = /Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)/mi
str = 'Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end