package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)`)
var str = `Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}