// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)Me llamo ([A-z]{3,}), tengo (\d{1,3}) años y vivo en ([A-z]+)").unwrap();
let string = "Me llamo Luis, tengo 29 años y vivo en Valencia y me gusta el deporte.
Hola, me llamo Ana, tengo 30 años y vivo en Valencia.
Me llamo Carlos, tengo 40 años y vivo en Madrid.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}