#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^([\p{L}](?:[\p{L} -]+[\p{L}])?)$"
Local $sString = "my string is nice 123 and it is cool" & @CRLF & _
"regular string" & @CRLF & _
"this is fine too" & @CRLF & _
"- starts with a dash" & @CRLF & _
"ends with a dash-" & @CRLF & _
"ends with a space " & @CRLF & _
"does not end with a space or a dash" & @CRLF & _
"a" & @CRLF & _
"-" & @CRLF & _
" " & @CRLF & _
"this however, is not"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")