const regex = /^([\p{L}](?:[\p{L} -]+[\p{L}])?)$/umg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\p{L}](?:[\\p{L} -]+[\\p{L}])?)$', 'umg')
const str = `my string is nice 123 and it is cool
regular string
this is fine too
- starts with a dash
ends with a dash-
ends with a space
does not end with a space or a dash
a
-
this however, is not`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}