package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\p{L}](?:[\p{L} -]+[\p{L}])?)$`)
var str = `my string is nice 123 and it is cool
regular string
this is fine too
- starts with a dash
ends with a dash-
ends with a space
does not end with a space or a dash
a
-
this however, is not`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}