// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)^([\p{L}](?:[\p{L} -]+[\p{L}])?)$").unwrap();
let string = "my string is nice 123 and it is cool
regular string
this is fine too
- starts with a dash
ends with a dash-
ends with a space
does not end with a space or a dash
a
-
this however, is not";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}