import re
regex = re.compile(r"^([\p{L}](?:[\p{L} -]+[\p{L}])?)$", flags=re.UNICODE | re.MULTILINE)
test_str = ("my string is nice 123 and it is cool\n"
"regular string\n"
"this is fine too\n"
"- starts with a dash\n"
"ends with a dash-\n"
"ends with a space \n"
"does not end with a space or a dash\n"
"a\n"
"-\n"
" \n"
"this however, is not")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")