use strict;
my $str = 'my string is nice 123 and it is cool
regular string
this is fine too
- starts with a dash
ends with a dash-
ends with a space
does not end with a space or a dash
a
-
this however, is not';
my $regex = qr/^([\p{L}](?:[\p{L} -]+[\p{L}])?)$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}