import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\p{L}](?:[\\p{L} -]+[\\p{L}])?)$";
final String string = "my string is nice 123 and it is cool\n"
+ "regular string\n"
+ "this is fine too\n"
+ "- starts with a dash\n"
+ "ends with a dash-\n"
+ "ends with a space \n"
+ "does not end with a space or a dash\n"
+ "a\n"
+ "-\n"
+ " \n"
+ "this however, is not";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}