#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))"
Local $sString = "bar(alvin the chipmunk dude)" & @CRLF & _
"chipmunk(alvin the chipmunk dude)" & @CRLF & _
"" & @CRLF & _
"I want to replace "chipmunk" on the first only (bar), could also be foo or any other beginning."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")