using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))";
string input = @"bar(alvin the chipmunk dude)
chipmunk(alvin the chipmunk dude)
I want to replace ""chipmunk"" on the first only (bar), could also be foo or any other beginning.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}