import re
regex = re.compile(r"chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))")
test_str = ("bar(alvin the chipmunk dude)\n"
"chipmunk(alvin the chipmunk dude)\n\n"
"I want to replace \"chipmunk\" on the first only (bar), could also be foo or any other beginning.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")