const regex = /chipmunk(?=[^\)\(\\]*(?:\\.[^\)\(\\]*)*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('chipmunk(?=[^\\)\\(\\\\]*(?:\\\\.[^\\)\\(\\\\]*)*\\))', 'g')
const str = `bar(alvin the chipmunk dude)
chipmunk(alvin the chipmunk dude)
I want to replace "chipmunk" on the first only (bar), could also be foo or any other beginning.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}